CCNA受験者必見! GNS3でOSPFシングルエリア設定を構築する完全手順をご紹介

mieruka.link読者の皆様、こんばんわ! 管理人の伊集院です。

Vmware Workstation 16 Pro + GNS3 2.2.17というとてつもなく快適な環境を手に入れた伊集院は、色々と本気で遊びはじめてしまいました。

OSPFのWiresharkプロファイルを作るのが目的で、GNS3上にOSPFのシングルエリア設定環境を作成したのですが、筆者がCCNA勉強している時代にこのような環境があれば理解や知識の定着に貢献したなと考え、今回はCCNA受験を控えている方や、GNS3を使ってみたいかた向けに記事を書いてみました。

OSPF環境の完成図は、以下の通りです。

図1 OSPF シングルエリア設定

ルーターx3台、PCx2台と非常にシンプルな構成です。

それでは、GNS3の操作からすべてご紹介します。

PCx2台の追加とIPアドレス設定

図2 VPCSの追加

GNS3のメニューから、VPCSを2台ドラック&ドロップして追加します。

PC1, PC2を起動してIPアドレスを設定します。

PC1> ip 172.31.0.100/24 172.31.0.1
Checking for duplicate address...
PC1 : 172.31.0.100 255.255.255.0 gateway 172.31.0.1

PC2> ip 192.168.10.100/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.100 255.255.255.0 gateway 192.168.10.1

ルーターx3台の追加・設定

図3 Cisco3725 x3 の追加

次に、Cisco3725x3台を追加します。

Cisco 3725をGNS3に追加するには、CiscoサイトにログインしてIOSをダウンロードする必要があります。

GNS3のデバイス追加画面からもCiscoサイトにリンクが張ってありますので、活用しましょう。

Ciscoパートナーでない方は、残念ながらIOSをダウンロードすることはできませんのでご注意ください。

図1のR1→R2→R3の順番で設定していきます。

3台のルーター設定の違いは、IPアドレス部分だけで残りは共通ですので、R1の設定だけを記載します。

図1のアドレスと見比べながら、R2, R3を設定していってください。

R1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#inte
R1(config)#interface F0/1
R1(config-if)#ip add
R1(config-if)#ip address 172.31.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#
R1(config)#interface FastEthernet 0/0
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#end
R1#wr
Building configuration...
[OK]
R1#
R1#config t
R1(config)#router ospf 1
R1(config-router)#network 172.31.0.1 0.0.0.0 area 0
R1(config-router)#network 10.0.0.1 0.0.0.0 area 0
R1(config-router)#end
R1#wr
Building configuration...
[OK]
R1#

最後に図1をみながら、PC1→R1→R2→R3とリンク接続してください。

この時、図1の注釈通りのインターフェイスペアで接続することに注意してください。

図4 リンクの接続

OSPF設定確認

“show ip ospf database”で、OSPFが有効になっていることを確認します。


R1#show ip ospf database

            OSPF Router with ID (172.31.0.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.0.1.1        10.0.1.1        964         0x80000005 0x00E5DE 2
172.31.0.1      172.31.0.1      1189        0x80000004 0x00DBB5 2
192.168.10.1    192.168.10.1    925         0x80000004 0x00AFE6 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.1        172.31.0.1      1189        0x80000002 0x004543
10.0.1.2        192.168.10.1    925         0x80000002 0x001C1B
R1#

どれか1台のルーターでコマンドを打てば、OSPFの設定がうまくいっているかを確認することができます。

上記は、R1で実行した結果ですが、PC2が存在する192.168.10.1迄、Router Link States(Area 0)に表示されていることが分かり、ルーティングされるといったことが確認できました。

Let’s enjoy GNS3 world!

(Visited 484 times, 1 visits today)
The following two tabs change content below.
【好きなもの】 インフラ技術が好き。古いものが好き。 【生きてきたフィールド】 システム運用、ソフトウェア開発、ミドルウェア検証、OSSサポート、プリセールスエンジニア、プロジェクトマネジメント 【このサイトでの役割】 サイト管理者。